Всё, что вы хотели знать о написании скриптов для JFW, но не знали, кого спросить

(Переработанный и дополненный вариант)
Источник:www.tiflocomp.ru
Дата публикации:2004
Twitter Facebook Vkontakte

Приложение B. Описание меню диспетчера скриптов

Ниже приводится краткое описание различных пунктов, доступных в раскрывающихся меню в линейке меню диспетчера скриптов. Описываются только элементы, уникальные для диспетчера скритов или те, которые выполняют необычные функции. Другие, которые являются стандартными для приложений Windows, обозначены как "Стандартные функции". Многие из описанных функций имеют клавиши быстрого доступа (hotkeys), которые перечислены в меню и которые вам, вероятно, захочется узнать.

Меню Файл

  • New (Создать) : Стандартная функция.
  • Open (Открыть): стандартная функция.
  • Open Default File (Открыть файл по умолчанию): открывает файл скриптов Jaws по умолчанию DEFAULT.JSS.
  • Close (Закрыть): стандартная функция.
  • Save (Сохранить): сохраняет файл, а также компилирует и сохраняет бинарную JSB версию, сохраняя .JSS файл.
  • Save As (Сохранить как): стандартная функция.
  • Save Without Compile (Сохранить без компиляции): сохраняет любой файл, и не компилирует .JSS файл.
  • Import Macro File (Импорт макроса): используется для импорта файла макроса из ранних версий JFW.
  • Synchronize Documentation (Синхронизировать документацию): используется, чтобы убедиться в том, что файлы скриптов и документация соответствуют друг другу. Также при вставке скриптов из других .JSS файлов, он скопирует документацию в соответствующий .JSD файл.
  • Print (Печать): стандартная функция.
  • Print Preview (Предварительный просмотр): стандартная функция.
  • Print Setup (Параметры страницы): стандартная функция.
  • Exit (Выход): стандартная функция.

Меню Edit

Все функции меню Edit совершенно стандартные, за исключением той, которая приведена ниже.

Select Script: выделяет скрипт целиком, в котором находится курсор.

Меню Script

  • New Script (Создать скрипт): открывается диалог New Script для создания нового скрипта.
  • Delete Script: удаляет скрипт, на котором находится курсор.
  • Insert Function Call (Вставить вызов функции): выводит диалог Insert Function для добавления в скрипт вызова функции.
  • Insert Perform Script (Вставить вызов скрипта): выводит диалог Insert Perform Script для вызова другого скрипта. Это аналогично вызову функции, но вызывается другой связанный с клавишей скрипт, а не функция.
  • Next Script: перемещает курсор к началу следующего скрипта в файле.
  • Prior Script: перемещает курсор к началу предыдущего скрипта в файле.
  • Go To Line: перемещает курсор к указанной строке. Номера страницы показаны на нижнем крае страницы.
  • Script List: выводит диалог Script List, в котором показаны скрипты в текущем файле в алфавитном порядке. Нажатие Enter на имени скрипта перемещает вас к этому скрипту.

Меню View

  • Documentation: выводит диалог Script Information, который содержит всю документацию для текущего скрипта, а также связанную с ним комбинацию клавиш.
  • Toolbar (Панель инструментов): стандартная функция.
  • Status Bar (Строка статуса): стандартная функция.
  • Zoom: стандартная функция.

Меню Window

Все элементы в меню Window выполняют стандартные функции.

Меню Help

  • Help Topics (Содержание): Стандартная функция.
  • keyword Help: выводит диалог KeyWord, который содержит помощь по скрипту или функции, на которой находится курсор.
  • About Script Manager (О программе): стандартная функция.


Распространение материалов сайта означает, что распространитель принял условия лицензионного соглашения.
Идея и реализация: © Владимир Довыденков и Анатолий Камынин,  2004-2019